Skip to end of metadata
Go to start of metadata

Before using the µC/OS BSP it must first be added to the Xilinx SDK development environment. The downloaded archive must be extracted to a suitable location preferably in a path without spaces. Once registered the location of Micriµm files should not be changed, otherwise the repository will have to be registered again.

A repository can be installed globally or locally, When installed globally it will be available across all workspace without having to register the BSP in each workspace. However, to prevent conflicting with other BSPs it is recommended to install the Micrium BSP only in the required workspaces.

 

It is possible to install more than one version of the repository in the same workspace. However Micrium does not support "mix and matching" components and drivers between repository versions.

Installation instructions

 

1. Open the repository add dialog from the Xilinx Tools->Repositories menu

2. Click New next to the "Local Repositories" section

3. Browse to the repository location and click Ok - The ucos sub-directory should be selected as shown in Figure - Xilinx SDK software repository add dialog


Figure - Xilinx SDK software repository add dialog


4. Verify installation

To verify that the repository is correctly registered you can try to generate a BSP with the File->New Board Support Package.The "ucos" BSP should be available in the list of supported BSPs.

 

Figure - Xilinx SDK New Board Support Package Dialog

Upgrade instructions

The recommended approach when upgrading to a new version of the μ C/OS BSP is to create a brand new BSP instead of updating the existing ones. To  upgrade the BSP version in an existing workspace Micrium recommends the following workflow :

  1. Extract the newly downloaded BSP in a new directory
  2. Install the repository in the current workspace. Making sure to keep the old one available.
  3. Generate a new BSP for your hardware platform using the File->New->Board Support Package
  4. Go through the various configurations to match the old BSP
  5. Change the BSP referenced by your projects. To do so right click on the project and select "Change Referenced BSP"
  6. Clean and Rebuild the project

At this point it's recommended to remove the previous repository to prevent driver and component conflicts.

Alternative approach

A faster but possibly less safe method is to change the current bsp version from the BSP Configuration dialog. It is recommended to save a backup of the current BSP in case you need to revert. After changing the version click the regenerate BSP sources button. Then clean and rebuild the project. If any configuration changed between BSP version they may not have been taken into consideration the first time. To fix this, after regenerating the BSP re-open the configuration dialog to take care of new/changed configurations.

After applying the previous steps, re-open the BSP configuration pane and update the version of every Micrium drivers used in the BSP to the latest version.

 

  • No labels